lkml.org 
[lkml]   [2019]   [May]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject5.1 kernel: khugepaged stuck at 100%
Date
Hello,

Kernel: 5.1 (self-compiled, no modules)
Arch: x86_64
Distro: Debian Testing

Issue: I was performing a dump of ext3 and ext4 filesystems and then
restoring them to a separate volume (testing)-- afterwards I noticed that
khugepaged is stuck at 100% CPU. It is currently still stuck at 100% CPU, is
there anything I can do to debug what is happening prior to a reboot to work
around the issue? I have never seen this behavior prior to 5.1.

$ cat /proc/cmdline
auto BOOT_IMAGE=5.1.0-2 ro root=901 3w-sas.use_msi=1 nohugeiomap
page_poison=1 pcie_aspm=off pti=on rootfstype=ext4 slub_debug=P
zram.enabled=1 zram.num_devices=12 zswap.enabled=1 zswap.compressor=lz4
zswap.zpool=z3fold

$ 5.1 .config attached: config.txt.gz

$ attachment: graphic.JPG -> graph of the processes, dark green ->
khugepaged

$ top

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
77 root 39 19 0 0 0 R 100.0 0.0 23:29.27
khugepaged
1 root 20 0 171800 7832 4948 S 0.0 0.0 1:25.59 systemd
2 root 20 0 0 0 0 S 0.0 0.0 0:00.02
kthreadd
3 root 0 -20 0 0 0 I 0.0 0.0 0:00.00 rcu_gp
4 root 0 -20 0 0 0 I 0.0 0.0 0:00.00
rcu_par_gp
6 root 0 -20 0 0 0 I 0.0 0.0 0:00.00
kworker/0+
8 root 0 -20 0 0 0 I 0.0 0.0 0:00.00
mm_percpu+

Thoughts on debugging / before reboot to clear this up?

Thanks,

Justin.
[unhandled content-type:application/x-gzip][unhandled content-type:image/jpeg]
\
 
 \ /
  Last update: 2019-05-09 11:55    [W:0.090 / U:2.960 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site