lkml.org 
[lkml]   [2019]   [May]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/2] serial: 8250: Add support for 8250/16550 as MFD function
On Tue, May 14, 2019 at 02:41:35PM +0200, Esben Haabendal wrote:
> Greg Kroah-Hartman <gregkh@linuxfoundation.org> writes:
>
> > On Tue, May 14, 2019 at 11:47:41AM +0100, Lee Jones wrote:
> >> On Tue, 14 May 2019, Esben Haabendal wrote:
> >>
> >> > Lee Jones <lee.jones@linaro.org> writes:
> >> >
> >> > > On Tue, 07 May 2019, Esben Haabendal wrote:
> >> > >
> >> > >> Lee Jones <lee.jones@linaro.org> writes:
> >> > >>
> >> > >> > On Fri, 26 Apr 2019, Esben Haabendal wrote:
> >> > >> >
> >> > >> >> The serial8250-mfd driver is for adding 8250/16550 UART ports as functions
> >> > >> >> to an MFD driver.
> >> > >> >>
> >> > >> >> When calling mfd_add_device(), platform_data should be a pointer to a
> >> > >> >> struct plat_serial8250_port, with proper settings like .flags, .type,
> >> > >> >> .iotype, .regshift and .uartclk. Memory (or ioport) and IRQ should be
> >> > >> >> passed as cell resources.
> >> > >> >
> >> > >> > What? No, please!
> >> > >> >
> >> > >> > If you *must* create a whole driver just to be able to use
> >> > >> > platform_*() helpers (which I don't think you should), then please
> >> > >> > call it something else. This doesn't have anything to do with MFD.
> >> > >>
> >> > >> True.
> >> > >>
> >> > >> I really don't think it is a good idea to create a whole driver just to
> >> > >> be able to use platform_get_*() helpers. And if I am forced to do this,
> >> > >> because I am unable to convince Andy to improve the standard serial8250
> >> > >> driver to support that, it should be called MFD. The driver would be
> >> > >
> >> > > I assume you mean "shouldn't"?
> >> >
> >> > Of-course.
> >> >
> >> > >> generally usable for all usecases where platform_get_*() works.
> >> > >>
> >> > >> I don't have any idea what to call such a driver. It really would just
> >> > >> be a fork of the current serial8250 driver, just allowing use of
> >> > >> platform_get_*(), supporting exactly the same hardware.
> >> > >>
> >> > >> I am still hoping that we can find a way to improve serial8250 to be
> >> > >> usable in these cases.
> >> > >
> >> > > Me too.
> >> >
> >> > Unfortunately, I don't seem to be able to convince Andy to accept
> >> > something like that.
> >>
> >> Andy is not he Maintainer.
> >>
> >> What are Greg and Jiri's opinions?
> >
> > I've been ignoring all of this at the moment because of the 5.2-rc merge
> > window. I'll look at it after -rc1 is out.
> >
> > thanks,
> > greg k-h
>
> Great, thanks!
>
> I will try ad hold back with this thread until you get back to it.

Ok, I have no idea what is going on here, sorry. This is a really long
and meandering thread, and I can't even find the original patches in my
queue.

So can you resend things and we can start over? :)

But note, using a mfd for a uart seems VERY odd to me...

thanks,

greg k-h

\
 
 \ /
  Last update: 2019-05-21 12:09    [W:0.079 / U:31.360 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site