lkml.org 
[lkml]   [2019]   [Apr]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH] platform/chrome: Add Wilco EC keyboard backlight LEDs support
On Thu, Apr 4, 2019 at 12:03 PM Pavel Machek <pavel@ucw.cz> wrote:
>
> On Thu 2019-04-04 09:13:27, Dmitry Torokhov wrote:
> > On Thu, Apr 4, 2019 at 4:24 AM Pavel Machek <pavel@ucw.cz> wrote:
> > >
> > > On Mon 2019-03-11 09:29:06, Nick Crews wrote:
> > > > Thanks for looking this over. I will fix most of your concerns, but
> > > > have one question.
> > > >
> > > > On Fri, Mar 8, 2019 at 2:08 PM Pavel Machek <pavel@ucw.cz> wrote:
> > > > >
> > > > > On Fri 2019-03-08 13:38:02, Nick Crews wrote:
> > > > > > This patch is meant to be applied on top of the for-next
> > > > > > branch of the platform/chrome repository, as it uses some of
> > > > > > the code staged there.
> > > > > >
> > > > > > The EC is in charge of controlling the keyboard backlight on
> > > > > > the Wilco platform. We expose a standard LED class device at
> > > > > > /sys/class/leds/wilco::kbd_backlight. This driver is modeled
> > > > > > after the standard Chrome OS keyboard backlight driver at
> > > > > > drivers/platform/chrome/cros_kbd_led_backlight.c
> > > > >
> > > > > Can you make it "platform::kbd_backlight"? We want some consistency
> > > > > there.
> > > >
> > > > The analogous name in the standard driver
> > > > drivers/platform/chrome/cros_kbd_led_backlight.c is
> > > > "chromeos::kbd_backlight", and I thought "wilco" was a better
> > > > substitute for "chromeos" than "platform" would be. What other thing
> > > > are you saying "platform" would be consistent with?
> > >
> > > Yeah, well, we not let the cros_kbd_led_backlight.c use chromeos:: in
> > > the first place. But it happened. We want all backlights for the
> > > system keyboard to use common name, and "chromeos" is not really
> > > suitable for that. "platform" is.
> >
> > Pavel, who exactly wants this and why? Looking at today's -next I see:
> >
> > dtor@dtor-ws:~/kernel/linux-next ((next-20190404))$ git grep
> > "::kbd_backlight" | wc -l
> > 18
> > dtor@dtor-ws:~/kernel/linux-next ((next-20190404))$ git grep
> > "platform::kbd_backlight" | wc -l
> > 0
> >
> > so there isn't a single instance of "platform::kbd_backlight" and we
> > definitely not changing existing names.
>
> Yeah, we made mistakes in the past. We _don't_ want userspace to have
> ever growing list of names for userspace to follow.
>
> Backlight of internal keyboard is pretty common concept and there
> should be one name for it.

It is the *function* that is interesting to userspace, not full name,
and we have proper standardization there.

I think before you demand changes in the drivers you need to get you
naming scheme get accepted into mainline
(Documentation/leds/leds-class.txt).

Thanks.

--
Dmitry

\
 
 \ /
  Last update: 2019-04-04 21:10    [W:0.061 / U:1.956 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site