[lkml]   [2019]   [Mar]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 2/3] mm/sparse: Optimize sparse_add_one_section()
On Wed, Mar 20, 2019 at 06:13:18PM +0800, Baoquan He wrote:
> + if (!memmap) {
> + ret = -ENOMEM;
> + goto out2;


Choose label names which say what the goto does or why the goto exists. An
example of a good name could be ``out_free_buffer:`` if the goto frees ``buffer``.
Avoid using GW-BASIC names like ``err1:`` and ``err2:``, as you would have to
renumber them if you ever add or remove exit paths, and they make correctness
difficult to verify anyway.

 \ /
  Last update: 2019-03-20 12:24    [W:0.121 / U:0.852 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site