lkml.org 
[lkml]   [2019]   [Mar]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/4] leds: netdev trigger: factor out middle part of device_name_store
Hello,

On Thu, Mar 14, 2019 at 11:15:28AM +0100, Pavel Machek wrote:
> On Thu 2019-03-14 10:31:11, Uwe Kleine-König wrote:
> 1;2802;0c> Hello,
> >
> > On Wed, Mar 13, 2019 at 09:26:13PM +0100, Rasmus Villemoes wrote:
> > > +static void set_device(struct led_netdev_data *trigger_data,
> > > + const char *buf, size_t size)
> >
> > "set_device" is a very generic name. Can you please prefix it with
> > "ledtrig_netdev_"?
>
> Its static.

Still it pollutes the name space for tools like ctags. Currently there
is no other driver that provides "set_device" but there are symbol names
that are used for different purposes and that's annoying. Right, for
global names that might even be used from other source files, this is
worse. But IMHO it's still annoying enough in cases like this to not do
it.

Best regards
Uwe

--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | http://www.pengutronix.de/ |

\
 
 \ /
  Last update: 2019-03-14 11:21    [W:0.079 / U:0.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site