[lkml]   [2019]   [Feb]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 20/35] ARM: davinci: cp-intc: add a wrapper around cp_intc_init()
On 1/31/19 7:39 AM, Bartosz Golaszewski wrote:
> From: Bartosz Golaszewski <>
> We're going to extend the cp_intc_init() function with a config
> structure so we can drop the intc-related fields from davinci_soc_info.
> Once we do it, we won't be able to use this routine directly as the
> init_irq callback. Wrap the calls in additional helpers that don't
> take parameters and can be assigned to init_irq.
> Signed-off-by: Bartosz Golaszewski <>
> ---

Reviewed-by: David Lechner <>

Also, same bikeshed comment about xxx_init_irq vs. xxx_init_irqs.

 \ /
  Last update: 2019-02-05 00:51    [W:0.488 / U:0.240 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site