lkml.org 
[lkml]   [2019]   [Feb]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 03/10] locking/rwsem: Rename kernel/locking/rwsem.h
On Tue, Feb 12, 2019 at 07:27:00PM -0500, Waiman Long wrote:
> The content of kernel/locking/rwsem.h is now specific to rwsem-xadd only.
> Rename it to rwsem-xadd.h to indicate that it is specific to rwsem-xadd
> and include it only when CONFIG_RWSEM_XCHGADD_ALGORITHM is set. As a result,
> the CONFIG_RWSEM_XCHGADD_ALGORITHM conditional compilation directives can
> be removed. There is no functional change.

Since all of rwsem-xadd is now generic code; how about we delete the
spinlock thing and keep everything rwsem ?

We don't carry a special spinlock mutex implementation either. And
arguably any arch that uses spinlock based atomics (afaict the only case
where rwsem-spinlock makes any sense anyway) suck anyway.

\
 
 \ /
  Last update: 2019-02-13 10:21    [W:0.164 / U:0.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site