lkml.org 
[lkml]   [2019]   [Dec]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [GIT PULL] treewide conversion to sizeof_member() for v5.5-rc1
On Sat, Dec 7, 2019 at 11:48 AM Kees Cook <keescook@chromium.org> wrote:
>
> Please pull this mostly mechanical treewide conversion to the single and
> more accurately named sizeof_member() macro for the end of v5.5-rc1.

So this one I'm _still_ not convinced about. It makes yet another name
for something we've had before, which just annoys me. And maybe it's
the 13-year old in me, but "sizeof_member()" just makes me go "that's
puerile".

I _can_ see why we'd want to standardize on one of the tree versions
we have, but I can't really see the problem with the existing #define
that we have, and that is used (admittedly not all that much):
sizeof_field().

Linus

\
 
 \ /
  Last update: 2019-12-09 00:20    [W:0.034 / U:12.760 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site