lkml.org 
[lkml]   [2019]   [Dec]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: [PATCH] ACPI: button: Add a DMI quirk for Razer Blade Stealth 13 late 2019 lid-switch
From
Date
Hi,

On 06-12-2019 18:54, Jason Ekstrand wrote:
> Running evemu-record on the lid switch event shows that the lid reports
> the first close but then never reports an open. This causes systemd to
> continuously re-suspend the laptop every 30s. Resetting the _LID to
> open fixes the issue.

Sorry to be a bit nitpicky here, but the LID does work normally right,
so it does signal an event when it gets closed a second time right?

Your current commit message and comment suggest closing the LID only
works once. So perhaps something like this for the comment:

/*
* Razer Blade Stealth 13 late 2019, _LID always reports closed,
* even when opened.
*/

And adjust the comment accordingly.

Regards,

Hans



> Signed-off-by: Jason Ekstrand <jason@jlekstrand.net>
> ---
>
> Re-sending due to a typo in my own e-mail address. :(
>
> drivers/acpi/button.c | 11 +++++++++++
> 1 file changed, 11 insertions(+)
>
> diff --git a/drivers/acpi/button.c b/drivers/acpi/button.c
> index 662e07afe9a1..f7ca94e41c48 100644
> --- a/drivers/acpi/button.c
> +++ b/drivers/acpi/button.c
> @@ -122,6 +122,17 @@ static const struct dmi_system_id dmi_lid_quirks[] = {
> },
> .driver_data = (void *)(long)ACPI_BUTTON_LID_INIT_OPEN,
> },
> + {
> + /*
> + * Razer Blade Stealth 13 late 2019, _LID reports the first
> + * close but never resets to open.
> + */
> + .matches = {
> + DMI_MATCH(DMI_SYS_VENDOR, "Razer"),
> + DMI_MATCH(DMI_PRODUCT_NAME, "Razer Blade Stealth 13 Late 2019"),
> + },
> + .driver_data = (void *)(long)ACPI_BUTTON_LID_INIT_OPEN,
> + },
> {}
> };
>
>

\
 
 \ /
  Last update: 2019-12-08 15:06    [W:0.054 / U:0.616 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site