lkml.org 
[lkml]   [2019]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [GIT PULL 0/6] perf/urgent fixes
Em Fri, Dec 06, 2019 at 08:57:01AM +0100, Ingo Molnar escreveu:
> Pulled, thanks a lot Arnaldo!

> JFYI, on my system the default perf/urgent build still has this noise
> generated by util/parse-events.y and util/expr.y:

> util/parse-events.y:1.1-12: warning: deprecated directive, use ‘%define api.pure’ [-Wdeprecated]
> 1 | %pure-parser
> | ^~~~~~~~~~~~
> util/parse-events.y: warning: fix-its can be applied. Rerun with option '--update'. [-Wother]
> util/expr.y:15.1-12: warning: deprecated directive, use ‘%define api.pure’ [-Wdeprecated]
> 15 | %pure-parser
> | ^~~~~~~~~~~~
> util/expr.y: warning: fix-its can be applied. Rerun with option '--update'. [-Wother]

I'll get to this, I've been postponing dealing with this nuisance as,
IIRC, this will make perf not build in systems with older bisons.

- Arnaldo

\
 
 \ /
  Last update: 2019-12-06 15:24    [W:0.066 / U:3.996 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site