lkml.org 
[lkml]   [2019]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: drivers/scsi/.tmp_mc_st.s:3: Error: invalid operands (*UND* and *UND* sections) for `^'
Greentime Hu <green.hu@gmail.com> 於 2019年12月6日 週五 下午4:19寫道:
>
> Arnd Bergmann <arnd@arndb.de> 於 2019年12月6日 週五 下午4:00寫道:
> >
> > On Fri, Dec 6, 2019 at 2:05 AM kbuild test robot <lkp@intel.com> wrote:
> > >
> > > tree: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git master
> > > head: 2f13437b8917627119d163d62f73e7a78a92303a
> > > commit: 1207045da5a7c94344e0ea9a9e7495985eef499a compat_ioctl: move tape handling into drivers
> > > date: 6 weeks ago
> > > config: nds32-allyesconfig (attached as .config)
> > > compiler: nds32le-linux-gcc (GCC) 9.2.0
> > > reproduce:
> > > wget https://raw.githubusercontent.com/intel/lkp-tests/master/sbin/make.cross -O ~/bin/make.cross
> > > chmod +x ~/bin/make.cross
> > > git checkout 1207045da5a7c94344e0ea9a9e7495985eef499a
> > > # save the attached .config to linux build tree
> > > GCC_VERSION=9.2.0 make.cross ARCH=nds32
> > >
> > > If you fix the issue, kindly add following tag
> > > Reported-by: kbuild test robot <lkp@intel.com>
> > >
> > > All errors (new ones prefixed by >>):
> > >
> > > drivers/scsi/.tmp_mc_st.s: Assembler messages:
> > > >> drivers/scsi/.tmp_mc_st.s:3: Error: invalid operands (*UND* and *UND* sections) for `^'
> > > drivers/scsi/.tmp_mc_st.s:4: Error: invalid operands (*UND* and *UND* sections) for `^'
> > > drivers/scsi/.tmp_mc_st.s:5: Error: invalid operands (*UND* and *UND* sections) for `^'
> > > drivers/scsi/.tmp_mc_st.s:6: Error: invalid operands (*UND* and *UND* sections) for `^'
> > > drivers/scsi/.tmp_mc_st.s:7: Error: invalid operands (*UND* and *UND* sections) for `^'
> > > drivers/scsi/.tmp_mc_st.s:8: Error: invalid operands (*UND* and *UND* sections) for `^'
> > > drivers/scsi/.tmp_mc_st.s:9: Error: invalid operands (*UND* and *UND* sections) for `^'
> >
> > Adding nds32 maintainers to Cc:
> >
> > It looks like a regression caused by my patch, but I don't think it's something
> > I did wrong, but rather a toolchain bug being uncovered by the modified sources.
> >
> > Are you able to reproduce this?
>
> Hi Arnd,
>
> I am trying to reproduce this problem, but it happened to me.
>
> greentimeh@gamma07:/scratch/greentimeh/nds32/linux <(1207045da5a7...)>
> $ GCC_VERSION=9.2.0 make.cross ARCH=nds32
> cd: received redirection to `https://download.01.org/0day-ci/cross-package/'
> Cannot find nds32-linux under
> https://download.01.org/0day-ci/cross-package check
> /tmp/crosstool-files
>
> Can you reproduce it?

I can reproduce it now by adding these 2 lines to make.cross.
177 nds32)
178 gcc_arch=nds32le-linux

It will be built failed with gcc-9.2.0-nolibc toolchain, but it can be
built pass with gcc-8.1.0-nolibc toolchain.

\
 
 \ /
  Last update: 2019-12-06 09:39    [W:0.063 / U:1.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site