lkml.org 
[lkml]   [2019]   [Dec]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] ath11k: Remove unnecessary enum scan_priority
Date
Nick Desaulniers <ndesaulniers@google.com> writes:

> On Thu, Dec 19, 2019 at 5:32 AM Kalle Valo <kvalo@codeaurora.org> wrote:
>>
>> Nick Desaulniers <ndesaulniers@google.com> writes:
>>
>> > On Wed, Dec 11, 2019 at 11:23 AM Nathan Chancellor
>> > <natechancellor@gmail.com> wrote:
>> >> wmi_scan_priority and scan_priority have the same values but the wmi one
>> >> has WMI prefixed to the names. Since that enum is already being used,
>> >> get rid of scan_priority and switch its one use to wmi_scan_priority to
>> >> fix this warning.
>> >>
>> > Also, I don't know if the more concisely named enum is preferable?
>>
>> I didn't get this comment.
>
> Given two enums with the same values:
> enum scan_priority
> enum wmi_scan_priority
> wouldn't you prefer to type wmi_ a few times less? Doesn't really
> matter, but that was the point I was making.

Ah, now I got it :) This enum is part of firmware interface (WMI) so
yes, I prefer to use the wmi_ prefix to make that obvious.

--
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches

\
 
 \ /
  Last update: 2019-12-20 08:20    [W:0.035 / U:3.724 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site