Messages in this thread |  | | Date | Mon, 16 Dec 2019 15:35:39 +0100 | From | Peter Zijlstra <> | Subject | Re: [Patch v6 2/7] sched: Add hook to read per cpu thermal pressure. |
| |
On Wed, Dec 11, 2019 at 11:11:43PM -0500, Thara Gopinath wrote: > Introduce arch_scale_thermal_capacity to retrieve per cpu thermal > pressure. > > Signed-off-by: Thara Gopinath <thara.gopinath@linaro.org> > --- > include/linux/sched/topology.h | 8 ++++++++ > 1 file changed, 8 insertions(+) > > diff --git a/include/linux/sched/topology.h b/include/linux/sched/topology.h > index f341163..f1e22f9 100644 > --- a/include/linux/sched/topology.h > +++ b/include/linux/sched/topology.h > @@ -225,6 +225,14 @@ unsigned long arch_scale_cpu_capacity(int cpu) > } > #endif > > +#ifndef arch_scale_thermal_capacity > +static __always_inline > +unsigned long arch_scale_thermal_capacity(int cpu) > +{ > + return 0; > +} > +#endif
This is confusing, the return value is not a capacity, it is a reduction in capacity. Either a comment of a better name would be appreciated.
|  |