lkml.org 
[lkml]   [2019]   [Dec]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRegression in 5.4 kernel on 32-bit Radeon IBM T40
Date
Regression in 5.4 kernel on 32-bit Radeon IBM T40
triggered by
commit 33b3ad3788aba846fc8b9a065fe2685a0b64f713
Author: Christoph Hellwig <hch@lst.de>
Date:   Thu Aug 15 09:27:00 2019 +0200

Howdy,
The above patch has triggered a display problem on IBM Thinkpad T40,
where the screen is covered with a lots of random short black horizontal
lines, or distorted letters in X terms.

The culprit seems to be that the dma_get_required_mask() is returning a
value 0x3fffffff
which is smaller than dma_get_mask()0xffffffff.That results in
dma_addressing_limited()==0 in ttm_bo_device(), and using 40-bits dma
instead of 32-bits.

If I hardcode "1" as the last parameter to ttm_bo_device_init() in place
of a call to dma_addressing_limited(),the problem goes away.

I have added the debug lines starting with "wms:" to the start of
radeon_ttm_init() and of radeon_device_init()printing the interesting
variables.
/....
[    2.091692] Linux agpgart interface v0.103
[    2.092380] agpgart-intel 0000:00:00.0: Intel 855PM Chipset
[    2.107706] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
[    2.108111] [drm] radeon kernel modesetting enabled.
[    2.108200] radeon 0000:01:00.0: vgaarb: deactivate vga console
[    2.109365] Console: switching to colour dummy device 80x25
******* radeon_device_init()
[    2.110712] wms: radeon_init flags = 0x90003
[    2.110718] [drm] initializing kernel modesetting (RV200
0x1002:0x4C57 0x1014:0x0530 0x00).
[    2.111220] agpgart-intel 0000:00:00.0: AGP 2.0 bridge
[    2.111233] agpgart-intel 0000:00:00.0: putting AGP V2 device into 1x
mode
[    2.111265] radeon 0000:01:00.0: putting AGP V2 device into 1x mode
[    2.111286] radeon 0000:01:00.0: GTT: 256M 0xD0000000 - 0xDFFFFFFF
[    2.111295] radeon 0000:01:00.0: VRAM: 128M 0x00000000E0000000 -
0x00000000E7FFFFFF (32M used)
[    2.111701] [drm] Detected VRAM RAM=128M, BAR=128M
[    2.111704] [drm] RAM width 64bits DDR
******* radeon_ttm_init()
[    2.111706] wms: dma_addressing_limited=0x0
[    2.111709] wms: dma_get_mask=0xffffffff, bus_dma_limit=0x0,
dma_get_required_mask=0x3fffffff
[    2.115971] [TTM] Zone  kernel: Available graphics memory: 437028 KiB
[    2.115973] [TTM] Zone highmem: Available graphics memory: 510440 KiB

What should be the proper value of these dma variables on the 32-bit system?
How to fix that issue correctly (patches welcomed :-) )Or is the
platform fubar?

Thanks, Woody


\
 
 \ /
  Last update: 2019-12-15 04:19    [W:0.075 / U:6.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site