lkml.org 
[lkml]   [2019]   [Dec]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC] btf: Some structs are doubled because of struct ring_buffer
On Fri, Dec 13, 2019 at 01:29:41PM -0500, Steven Rostedt wrote:
> On Fri, 13 Dec 2019 19:02:23 +0100
> Peter Zijlstra <peterz@infradead.org> wrote:

> > Your ring buffer was so generic that I gave up trying to use it after
> > trying for days :-( (the fundamental problem was that it was impossible
> > to have a single cpu buffer; afaik that is still true today)
>
> Yeah, but that could have been fixed, and the only reason it's not
> today, is because it requires more overhead to do so.
>
> IIRC, the main reason that you didn't use it then, is because it wasn't
> fully lockless at the time (it is today), and you couldn't use it from
> NMI context.

What I remember is that I couldn't get a single cpu buffer, the whole
per-cpu stuff was mangled in at the wrong layer. But who knows, my
memory is faulty.


> > How about we rename both? I'm a bit adverse to long names, so how about
> > we rename the perf one to perf_buffer and the trace one to trace_buffer?
>
> I'm fine with this idea! Now what do we call the ring buffer that
> tracing uses, as it is not specific for tracing, it was optimized for
> splicing. But sure, I can rename it to trace_buffer. I just finished
> renaming perf's...
>
> Thinking about this, perhaps we should remove the word "ring" from
> both. That is:
>
> perf_buffer and trace_buffer ?

That's what I just proposed, right? So ACK on that ;-)

\
 
 \ /
  Last update: 2019-12-13 19:47    [W:0.043 / U:1.572 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site