[lkml]   [2019]   [Dec]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subject[PATCH v2 0/3] Use new GPIO direction defines for intel pinctrl
We added definitions for GPIO line directions here:

Let's use them on Intel pincontrollers too.

Changes for v2:
- Replaced ternary operator with if() for better readability


Matti Vaittinen (3):
pinctrl: pinctrl-intel: Use GPIO direction definitions
pinctrl: pinctrl-cherryview: Use GPIO direction definitions
pinctrl: pinctrl-baytrail: Use GPIO direction definitions

drivers/pinctrl/intel/pinctrl-baytrail.c | 4 ++--
drivers/pinctrl/intel/pinctrl-cherryview.c | 5 ++++-
drivers/pinctrl/intel/pinctrl-intel.c | 5 ++++-
3 files changed, 10 insertions(+), 4 deletions(-)

base-commit: e42617b825f8 ("Linux 5.5-rc1")

Matti Vaittinen, Linux device drivers
ROHM Semiconductors, Finland SWDC
Kiviharjunlenkki 1E
90220 OULU

~~~ "I don't think so," said Rene Descartes. Just then he vanished ~~~
Simon says - in Latin please.
~~~ "non cogito me" dixit Rene Descarte, deinde evanescavit ~~~
Thanks to Simon Glass for the translation =]

 \ /
  Last update: 2019-12-12 07:34    [W:0.043 / U:5.220 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site