lkml.org 
[lkml]   [2019]   [Dec]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 5/7] arm64: dts: qcom: sc7180: Avoid "memory" for cmd-db reserved-memory node
On Thu 12 Dec 11:35 PST 2019, Douglas Anderson wrote:

> By using "memory" we trigger we trigger the "schemas/memory.yaml"
> rules when we run "dtbs_check" which then complains that we don't have
> a "device_type" of "memory".
>

I like "memory" here, so we have a whole bunch of these to fix up in
various dts files...

@Rob, should we move away to descriptive node names or to some other
generic name for entries in reseved-memory?

Regards,
Bjorn

> Looking at the "reserved-memory.txt" bindings, subnodes shouldn't just
> be the word "memory". Presumably using just "cmd-db" should be OK for
> a node name.
>
> Fixes: e0abc5eb526e ("arm64: dts: qcom: sc7180: Add cmd_db reserved area")
> Signed-off-by: Douglas Anderson <dianders@chromium.org>
> ---
>
> arch/arm64/boot/dts/qcom/sc7180.dtsi | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/arm64/boot/dts/qcom/sc7180.dtsi b/arch/arm64/boot/dts/qcom/sc7180.dtsi
> index d114feade8e7..9766867abc88 100644
> --- a/arch/arm64/boot/dts/qcom/sc7180.dtsi
> +++ b/arch/arm64/boot/dts/qcom/sc7180.dtsi
> @@ -61,7 +61,7 @@ reserved_memory: reserved-memory {
> #size-cells = <2>;
> ranges;
>
> - aop_cmd_db_mem: memory@80820000 {
> + aop_cmd_db_mem: cmd-db@80820000 {
> reg = <0x0 0x80820000 0x0 0x20000>;
> compatible = "qcom,cmd-db";
> no-map;
> --
> 2.24.1.735.g03f4e72817-goog
>

\
 
 \ /
  Last update: 2019-12-13 00:19    [W:0.109 / U:4.232 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site