lkml.org 
[lkml]   [2019]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectlinux-next: build warning after merge of the powerpc tree
Hi all,

After merging the powerpc tree, today's linux-next build (x86_64
allmodconfig) produced this warning:

security/integrity/platform_certs/load_uefi.c:17:19: warning: 'efi_cert_sha256_guid' defined but not used [-Wunused-variable]
17 | static efi_guid_t efi_cert_sha256_guid __initdata = EFI_CERT_SHA256_GUID;
| ^~~~~~~~~~~~~~~~~~~~
security/integrity/platform_certs/load_uefi.c:15:19: warning: 'efi_cert_x509_sha256_guid' defined but not used [-Wunused-variable]
15 | static efi_guid_t efi_cert_x509_sha256_guid __initdata =
| ^~~~~~~~~~~~~~~~~~~~~~~~~
security/integrity/platform_certs/load_uefi.c:14:19: warning: 'efi_cert_x509_guid' defined but not used [-Wunused-variable]
14 | static efi_guid_t efi_cert_x509_guid __initdata = EFI_CERT_X509_GUID;
| ^~~~~~~~~~~~~~~~~~

Introduced by commit

ad723674d675 ("x86/efi: move common keyring handler functions to new file")

--
Cheers,
Stephen Rothwell
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2019-11-13 23:35    [W:0.073 / U:1.896 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site