lkml.org 
[lkml]   [2019]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH RFC 2/3] sched: idle: Add a latency parameter to the play_idle function
On Wed, Nov 13, 2019 at 7:54 PM Daniel Lezcano
<daniel.lezcano@linaro.org> wrote:
>
> By default the play_idle() function leads to the deepest idle state
> selection which is not necessarily the state we are interested in when
> forcing the CPU to go to idle.
>
> Add a latency parameter to the play_idle() function, so the caller can
> use the constraint to allow a shallower state.
>
> Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
> ---
> drivers/powercap/idle_inject.c | 2 +-
> drivers/thermal/intel/intel_powerclamp.c | 2 +-
> include/linux/cpu.h | 2 +-
> kernel/sched/idle.c | 4 ++--
> 4 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/powercap/idle_inject.c b/drivers/powercap/idle_inject.c
> index cd1270614cc6..6f2bfb172e61 100644
> --- a/drivers/powercap/idle_inject.c
> +++ b/drivers/powercap/idle_inject.c
> @@ -138,7 +138,7 @@ static void idle_inject_fn(unsigned int cpu)
> */
> iit->should_run = 0;
>
> - play_idle(READ_ONCE(ii_dev->idle_duration_us));
> + play_idle(READ_ONCE(ii_dev->idle_duration_us), UINT_MAX);
> }
>
> /**
> diff --git a/drivers/thermal/intel/intel_powerclamp.c b/drivers/thermal/intel/intel_powerclamp.c
> index 53216dcbe173..dd1330d59176 100644
> --- a/drivers/thermal/intel/intel_powerclamp.c
> +++ b/drivers/thermal/intel/intel_powerclamp.c
> @@ -430,7 +430,7 @@ static void clamp_idle_injection_func(struct kthread_work *work)
> if (should_skip)
> goto balance;
>
> - play_idle(jiffies_to_usecs(w_data->duration_jiffies));
> + play_idle(jiffies_to_usecs(w_data->duration_jiffies), UINT_MAX);
>
> balance:
> if (clamping && w_data->clamping && cpu_online(w_data->cpu))
> diff --git a/include/linux/cpu.h b/include/linux/cpu.h
> index d0633ebdaa9c..241f558af17a 100644
> --- a/include/linux/cpu.h
> +++ b/include/linux/cpu.h
> @@ -179,7 +179,7 @@ void arch_cpu_idle_dead(void);
> int cpu_report_state(int cpu);
> int cpu_check_up_prepare(int cpu);
> void cpu_set_state_online(int cpu);
> -void play_idle(unsigned long duration_us);
> +void play_idle(unsigned long duration_us, unsigned int latency);
>
> #ifdef CONFIG_HOTPLUG_CPU
> bool cpu_wait_death(unsigned int cpu, int seconds);
> diff --git a/kernel/sched/idle.c b/kernel/sched/idle.c
> index 00e064d3dfe1..56a8b9d35cb9 100644
> --- a/kernel/sched/idle.c
> +++ b/kernel/sched/idle.c
> @@ -311,7 +311,7 @@ static enum hrtimer_restart idle_inject_timer_fn(struct hrtimer *timer)
> return HRTIMER_NORESTART;
> }
>
> -void play_idle(unsigned long duration_us)
> +void play_idle(unsigned long duration_us, unsigned int latency)

I'd rather rename this to something like play_idle_precise() and
redefine play_idle() as a single-argument wrapper around it.

Maybe also change the first arg to ns while at it (and keep us in play_idle())?

> {
> struct idle_timer it;
>
> @@ -328,7 +328,7 @@ void play_idle(unsigned long duration_us)
> rcu_sleep_check();
> preempt_disable();
> current->flags |= PF_IDLE;
> - cpuidle_use_latency(1);
> + cpuidle_use_latency(latency);
>
> it.done = 0;
> hrtimer_init_on_stack(&it.timer, CLOCK_MONOTONIC, HRTIMER_MODE_REL);
> --
> 2.17.1
>

\
 
 \ /
  Last update: 2019-11-13 23:09    [W:0.074 / U:0.740 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site