[lkml]   [2019]   [Oct]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] KVM: X86: Make fpu allocation a common function
On 14/10/19 18:58, Vitaly Kuznetsov wrote:
> Xiaoyao Li <> writes:
>> They are duplicated codes to create vcpu.arch.{user,guest}_fpu in VMX
>> and SVM. Make them common functions.
>> No functional change intended.
> Would it rather make sense to move this code to
> kvm_arch_vcpu_create()/kvm_arch_vcpu_destroy() instead?

user_fpu could be made percpu too... That would save a bit of memory
for each vCPU. I'm holding on Xiaoyao's patch because a lot of the code
he's touching would go away then.


 \ /
  Last update: 2019-10-15 11:29    [W:0.057 / U:4.312 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site