lkml.org 
[lkml]   [2019]   [Jan]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: linux-next: build warning after merge of the spi tree
Date
Hi,

> -----Original Message-----
> From: Stephen Rothwell [mailto:sfr@canb.auug.org.au]
> Sent: Tuesday, January 29, 2019 7:33 AM
> To: Mark Brown <broonie@kernel.org>
> Cc: Linux Next Mailing List <linux-next@vger.kernel.org>; Linux Kernel Mailing
> List <linux-kernel@vger.kernel.org>; Yogesh Narayan Gaur
> <yogeshnarayan.gaur@nxp.com>; Frieder Schrempf
> <frieder.schrempf@kontron.de>; Boris Brezillon <bbrezillon@kernel.org>;
> Ashish Kumar <ashish.kumar@nxp.com>
> Subject: linux-next: build warning after merge of the spi tree
>
> Hi all,
>
> After merging the spi tree, today's linux-next build (KCONFIG_NAME) produced
> this warning:
>
> WARNING: modpost: missing MODULE_LICENSE() in drivers/spi/spi-nxp-fspi.o
> see include/linux/module.h for more information
>
Can someone help in pointing out that why above warning message is coming for mentioned commit.
Below MODULE_LICENSE string is present in the above mentioned file, drivers/spi/spi-nxp-fspi.c.
MODULE_LICENSE("GPL v2");

--
Regards,
Yogesh Gaur
> Introduced by commit
>
> a5356aef6a90 ("spi: spi-mem: Add driver for NXP FlexSPI controller")
>
> --
> Cheers,
> Stephen Rothwell

\
 
 \ /
  Last update: 2019-01-29 07:58    [W:0.115 / U:3.860 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site