lkml.org 
[lkml]   [2019]   [Jan]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] n_tty: update comment for WAKEUP_CHARS define
On Wed, Jan 02, 2019 at 07:48:42AM +0100, Jiri Slaby wrote:
> On 29. 12. 18, 13:48, Valentin Vidic wrote:
> > Give a better descriptions of what WAKEUP_CHARS represents.
> >
> > Signed-off-by: Valentin Vidic <Valentin.Vidic@CARNet.hr>
>
> I am not a native speaker, but this is much better than the current text.
>
> Acked-by: Jiri Slaby <jslaby@suse.cz>
>
> BTW this text is copy&pasted from/to all the other WAKEUP_CHARS
> locations. Care to fix them all?

Yes, I've seen other instances of WAKEUP_CHARS but they don't look like
the same thing, for example:

rocket_int.h:/* number of characters left in xmit buffer before we ask for more */
rocket_int.h:#define WAKEUP_CHARS 256

rocket.c: if (info->xmit_cnt < WAKEUP_CHARS) {
rocket.c: tty_wakeup(tty);

Maybe the instance in n_tty.c could use a better name instead?

--
Valentin

\
 
 \ /
  Last update: 2019-01-02 10:50    [W:0.039 / U:7.728 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site