lkml.org 
[lkml]   [2019]   [Jan]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] arm64: dts: hikey: Give wifi some time after power-on
From
Date
On 06.01.19 10:53, Jan Kiszka wrote:
> On 03.01.19 22:32, Ulf Hansson wrote:
>> On Wed, 2 Jan 2019 at 23:21, John Stultz <john.stultz@linaro.org> wrote:
>>>
>>> Adding a few folks to cc from the thread here:
>>> https://patchwork.kernel.org/patch/10734021/
>>>
>>> As this sounds like a very similar issue.
>>> thanks
>>> -john
>>
>> John, thanks for looping me in.
>>
>>>
>>> On Sun, Dec 30, 2018 at 3:38 AM Jan Kiszka <jan.kiszka@web.de> wrote:
>>>>
>>>> From: Jan Kiszka <jan.kiszka@siemens.com>
>>>>
>>>> Somewhere along recent changes to power control of the wl1835, power-on
>>>> became very unreliable on the hikey, failing like this:
>>>>
>>>> wl1271_sdio: probe of mmc2:0001:1 failed with error -16
>>>> wl1271_sdio: probe of mmc2:0001:2 failed with error -16
>>>>
>>>> After playing with some dt parameters and comparing to other users of
>>>> this chip, it turned out we need some power-on delay to make things
>>>> stable again. In contrast to those other users which define 200 ms, the
>>>> hikey is already very happy with 1 ms.
>>
>> According to the discussions we had so far, this doesn't sound like
>> the correct solution.
>>
>> I am intending to post patch soon, however, I am not sure exactly what
>> solution to pick yet. I will keep you on cc - and of course I
>> appreciate if you could help to test.
>>
>
> FWIW, the Ultra96 is also affected. Here I worked around it by using a 10 ms
> power-on delay. The original workaround from the other thread did not help.
> Looking forward to the proper fix now!
>

Any news on this regression?

Jan

\
 
 \ /
  Last update: 2019-01-15 09:11    [W:0.059 / U:7.568 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site