[lkml]   [2019]   [Jan]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 2/6] crypto: kdf - SP800-108 Key Derivation Function
Am Samstag, 12. Januar 2019, 06:27:59 CET schrieb Eric Biggers:

Hi Eric,

> >
> > +obj-$(CONFIG_CRYPTO_KDF) += kdf.o
> This naming is too generic. CONFIG_CRYPTO_KDF and kdf.c imply that this is
> related to all KDFs. But actually it is an implementation of a few specific
> KDFs. Can you give it a clearer name, like KDF_SP800?
I am going to use kdf_sp800108 or CRYPTO_CONFIG_KDF_SP800108. The reason is
that there are many SP800 documents.



 \ /
  Last update: 2019-01-14 10:32    [W:0.115 / U:2.356 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site