lkml.org 
[lkml]   [2018]   [Sep]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] mtd: nand: denali: use SPDX-License-Identifier and fix license mismatch
Hi Masahiro,

Masahiro Yamada <yamada.masahiro@socionext.com> wrote on Mon, 20 Aug
2018 12:26:36 +0900:

> Use SPDX-License-Identifier instead of the license boilerplates.
>
> This conversion makes it easier for us to scan the license, then
> I notice license mismatch problems.
>
> The license blocks in denali* indicate GPL-2.0 "only", while the
> MODULE_LICENSE in denali.c and denali_dt.c is GPL-2.0 "or later"
> as explained in include/linux/module.h as follows:
>
> "GPL" [GNU Public License v2 or later]
> "GPL v2" [GNU Public License v2]
>
> I fixed the MODULE_LICENSE tags, assuming the license blocks are
> the authors' intention.
>
> Also, add missing MODULE_DESCRIPTION/AUTHOR to denali.c
>
> While I am touching the license things, I added my credit to denali.c
> because this driver was largely re-written by me in 2017.
>
> Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
> ---

Applied to nand/next with subject prefix s/nand/rawnand/.

Thanks,
Miquèl

\
 
 \ /
  Last update: 2018-09-04 23:59    [W:0.036 / U:0.656 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site