lkml.org 
[lkml]   [2018]   [Sep]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Make perf script easier to use for itrace
> (Ubuntu 18.04):
>
> builtin-script.c: In function ‘parse_output_fields’:
> builtin-script.c:2571:22: error: array subscript is above array bounds [-Werror=array-bounds]
> output[j].fields &= ~all_output_options[i].field;
> ^~
> builtin-script.c:2571:22: error: array subscript is above array bounds [-Werror=array-bounds]
> output[j].fields &= ~all_output_options[i].field;
> ~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> builtin-script.c:2574:10: error: array subscript is above array bounds [-Werror=array-bounds]
> output[j].user_set = true;
> ~~~~~~^~~
> builtin-script.c:2575:10: error: array subscript is above array bounds [-Werror=array-bounds]
> output[j].wildcard_set = true;
> ~~~~~~^~~

These were fixed earlier in -3.

> ...
> util/cs-etm.c: In function ‘cs_etm__process_auxtrace_info’:
> util/cs-etm.c:1436:14: error: ‘struct perf_session’ has no member named ‘itrace_synth’; did you mean ‘itrace_synth_opts’?
> session->itrace_synth.default_no_sample);
> ^~~~~~~~~~~~
> itrace_synth_opts

For some reason my x86 targetted build doesn't seem to cover this file, so
I missed it. What do I need to do to enable it?

-Andi

\
 
 \ /
  Last update: 2018-09-03 17:51    [W:0.098 / U:2.280 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site