[lkml]   [2018]   [Sep]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/3] drivers/base: move device_shutdown() to base/power
On Fri, Sep 14, 2018 at 5:10 PM Rafael J. Wysocki <> wrote:
> On Monday, August 20, 2018 11:18:35 AM CEST Pingfan Liu wrote:
> > Consider the shutdown as a system state transition, i.e. something like
> > suspend, hibernate, hence move it under the base/power. (This is a first
> > step to unify the duplicate code logic on devices_kset and dpm_list.)
> I don't really think that device_shutodwn() belongs in base/power/.
> Moving it to a separate file sounds like a good idea, but let that file
> reside in base/ proper.
> Then, I would separate the dpm_list definition, locking etc out of
> base/power/, move it to the new file containing device_shutdown() and
> make the code in base/power/ refer to it (you may want to move the list
> entry list head from dev_pm_info to struct device directly while at that
> too).
> Then, it should be straightforward enough to switch device_shutdown() over to
> using it.
Thanks for your advice. I will find a time slot to redo it.


 \ /
  Last update: 2018-09-19 05:57    [W:0.048 / U:6.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site