lkml.org 
[lkml]   [2018]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v1 2/5] dt-binding: rtc-pcf85063: add quartz load property
Hi,

You can remove 'rtc-' from the part name in the subject.

On 07/09/2018 21:35:05+0200, Sam Ravnborg wrote:
> From: Søren Andersen <san@skov.dk>
>
> The NXP pcf85063 support two different quartz loads.
> - 7 pF (default)
> - 12.5 pF (minimum power consumption)
>
> The pcf85063 needs to know the size of the external capacitor,
> otherwise the RTC will have a bad precision (hours/week).
>
> The power-on default is 7 pF
> Add a property that tells if the external capacitor is 12.5 pF
>
> Signed-off-by: Søren Andersen <san@skov.dk>
> Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
> Cc: Alessandro Zummo <a.zummo@towertech.it>
> Cc: Alexandre Belloni <alexandre.belloni@bootlin.com>
> Cc: Rob Herring <robh+dt@kernel.org>
> Cc: Mark Rutland <mark.rutland@arm.com>
> ---
> .../devicetree/bindings/rtc/nxp,pcf85063.txt | 19 +++++++++++++++++++
> Documentation/devicetree/bindings/trivial-devices.txt | 1 -
> 2 files changed, 19 insertions(+), 1 deletion(-)
> create mode 100644 Documentation/devicetree/bindings/rtc/nxp,pcf85063.txt
>
> diff --git a/Documentation/devicetree/bindings/rtc/nxp,pcf85063.txt b/Documentation/devicetree/bindings/rtc/nxp,pcf85063.txt
> new file mode 100644
> index 000000000000..22ebb2ce52c1
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/rtc/nxp,pcf85063.txt
> @@ -0,0 +1,19 @@
> +* NXP PCF85063 Real Time Clock
> +
> +NXP PCF85063 Real Time Clock
> +
> +Required properties:
> +- compatible: Should contain "nxp,pcf85063".
> +- reg: I2C address for chip.
> +
> +Optional property:
> +- nxp,quartz_load_12.5pF: The capacitive load on the quartz is 12.5 pF,
> + which differ from the default value of 7 pF
> +
> +Example:
> +
> +pcf85063: pcf85063@51 {
> + compatible = "nxp,pcf85063";
> + reg = <0x51>;
> + nxp,quartz_load_12.5pF;

Same comment as the previous patch, a value in fF is more useful. It
could also probably be made a generic rtc property.


--
Alexandre Belloni, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com

\
 
 \ /
  Last update: 2018-09-13 21:13    [W:0.065 / U:3.376 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site