lkml.org 
[lkml]   [2018]   [Aug]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] lightnvm: pblk: remove unnecessary drive version check
Date
> On 2 Aug 2018, at 22.58, Matias Bjørling <mb@lightnvm.io> wrote:
>
> The nvme driver checks for 1.2 and 2.0 compatibility. If an unsupported
> version is reported, the device will not be initialized.
>
> Signed-off-by: Matias Bjørling <mb@lightnvm.io>
> ---
> drivers/lightnvm/pblk-init.c | 8 --------
> 1 file changed, 8 deletions(-)
>
> diff --git a/drivers/lightnvm/pblk-init.c b/drivers/lightnvm/pblk-init.c
> index 537e98f2b24a..e9e2fedff387 100644
> --- a/drivers/lightnvm/pblk-init.c
> +++ b/drivers/lightnvm/pblk-init.c
> @@ -1202,14 +1202,6 @@ static void *pblk_init(struct nvm_tgt_dev *dev, struct gendisk *tdisk,
> pblk->state = PBLK_STATE_RUNNING;
> pblk->gc.gc_enabled = 0;
>
> - if (!(geo->version == NVM_OCSSD_SPEC_12 ||
> - geo->version == NVM_OCSSD_SPEC_20)) {
> - pblk_err(pblk, "OCSSD version not supported (%u)\n",
> - geo->version);
> - kfree(pblk);
> - return ERR_PTR(-EINVAL);
> - }
> -
> if (geo->version == NVM_OCSSD_SPEC_12 && geo->dom & NVM_RSP_L2P) {
> pblk_err(pblk, "host-side L2P table not supported. (%x)\n",
> geo->dom);
> --
> 2.11.0

The same comment goes for this patch. pblk does support 2.0 and 1.2
today, but it is not guaranteed it will support a new revision straight
away. So I think that a check wither here or through the .capabilities I
proposed on the other patch is necessary.

Javier
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2018-08-03 14:19    [W:0.055 / U:5.828 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site