lkml.org 
[lkml]   [2018]   [Jul]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/6] device: Add #define dev_fmt similar to #define pr_fmt
On Wed, May 09, 2018 at 08:15:46AM -0700, Joe Perches wrote:
> Add a prefixing macro to dev_<level> uses similar to the pr_fmt
> prefixing macro used in pr_<level> calls.
>
> This can help avoid some string duplication in dev_<level> uses.
>
> The default, like pr_fmt, is an empty #define dev_fmt(fmt) fmt
>
> Rename the existing dev_<level> functions to _dev_<level> and
> introduce #define dev_<level> _dev_<level> macros that use the
> new #define dev_fmt
>
> Miscellanea:
>
> o Consistently use #defines with fmt, ... and ##__VA_ARGS__
> o Remove unnecessary externs

SHouldn't these be separate patches please?

> Signed-off-by: Joe Perches <joe@perches.com>
> ---
> drivers/base/core.c | 12 +++---
> include/linux/device.h | 103 ++++++++++++++++++++++++++++---------------------
> 2 files changed, 64 insertions(+), 51 deletions(-)

Ok this seems like a lot of churn for no real apparent gain. What is
all of this getting us? What is the benifit, you have more code now,
why is that good?

confused,

greg k-h

\
 
 \ /
  Last update: 2018-07-06 17:31    [W:0.603 / U:2.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site