lkml.org 
[lkml]   [2018]   [Jul]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] iommu/amd: fix missing tag from dev_err message
From
Date
On 07/03/2018 05:07 AM, Joe Perches wrote:
> On Tue, 2018-07-03 at 07:40 +0100, Colin King wrote:
>> Currently tag is being assigned but not used, it is missing from
>> the dev_err message, so add it in.
>>
>> Cleans up clang warning:
>> warning: variable 'tag' set but not used [-Wunused-but-set-variable]
> []
>> diff --git a/drivers/iommu/amd_iommu.c b/drivers/iommu/amd_iommu.c
> []
>> @@ -616,9 +616,9 @@ static void iommu_print_event(struct amd_iommu *iommu, void *__evt)
>> pasid = ((event[0] >> 16) & 0xFFFF)
>> | ((event[1] << 6) & 0xF0000);
>> tag = event[1] & 0x03FF;
>> - dev_err(dev, "INVALID_PPR_REQUEST device=%02x:%02x.%x pasid=0x%05x address=0x%016llx flags=0x%04x]\n",
>> + dev_err(dev, "INVALID_PPR_REQUEST device=%02x:%02x.%x pasid=0x%05x address=0x%016llx flags=0x%04x tag=0x%03x]\n",
>> PCI_BUS_NUM(devid), PCI_SLOT(devid), PCI_FUNC(devid),
>> - pasid, address, flags);
>> + pasid, address, flags, tag);
>
> Seems to have a superfluous ] that should be removed.

Yeah, I pretty much messed up all of the log messages in that function.
My apologies. I'll create a patch for that problem; it shouldn't be
fixed here.

\
 
 \ /
  Last update: 2018-07-03 14:58    [W:0.094 / U:4.484 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site