lkml.org 
[lkml]   [2018]   [Jul]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] tick: prefer a lower rating device only if it's CPU local device
On Mon, Jul 02, 2018 at 04:44:33PM -0700, Kevin Hilman wrote:
> Hi Sudeep,
>
> On Wed, May 9, 2018 at 9:02 AM Sudeep Holla <sudeep.holla@arm.com> wrote:
> >
> > Checking the equality of cpumask for both new and old tick device doesn't
> > ensure that it's CPU local device. This will cause issue if a low rating
> > clockevent tick device is registered first followed by the registration
> > of higher rating clockevent tick device.
> >
> > In such case, clockevents_released list will never get emptied as both
> > the devices get selected as preferred one and we will loop forever in
> > clockevents_notify_released.
> >
> > Cc: Frederic Weisbecker <fweisbec@gmail.com>
> > Cc: Thomas Gleixner <tglx@linutronix.de>
> > Signed-off-by: Sudeep Holla <sudeep.holla@arm.com>
>
> I've got a arm32 board (meson8b-odroidc1) that's been failing in
> kernelCI.org since the merge window (boot log[1]), and I finally got
> around to bisecting it[2]. Unfortunately, the bisect pointed at a
> merge commit, but with some trial and error (and a suggestion by Arnd)
> I was able to test that revering $SUBJECT commit[3], my problem goes
> away.
>

Interesting. Sorry for causing the regression.

> Another interesting data point is that disabling SMP (either by
> "nosmp" on the command-line or CONFIG_SMP=n) also makes the problem go
> away, without needing to revert this patch.
>

I am not sure of nosmp, but with CONFIG_SMP=n, TICK_BROADCAST also gets
disabled. dummy_timer won't be registered I assume.

I am not sure if dummy_timer is selected as it's per_cpu but the rating
is low anyways.

> AFAICT, this platform, is using a single timer as a clocksource
> ("amlogic,meson6-timer") which is not a per-CPU timer.
>

Yes that's what I could gather from DT. But this is A5 right ? It may
have per CPU TWD(watchdof timer) but DT doesn't specify it, so should be
fine.

> I ran out of time to keep digging on this issue, and I'm still not
> sure exactly what's going on, but I wanted to report it in case anyone
> else has any ideas, and so we can hopefully get it fixed during the
> -rc cycle.
>

From the log, it looks like the platform has booted to userspace. Any chance
we can have a look at:
$ grep "" /sys/devices/system/clock*/{broadcast,clock*}/{available,current}_*

--
Regards,
Sudeep

\
 
 \ /
  Last update: 2018-07-03 12:55    [W:0.160 / U:4.280 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site