lkml.org 
[lkml]   [2018]   [Jul]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v6 9/9] x86: jump-labels: use macros instead of inline assembly
Date
at 7:26 AM, Ingo Molnar <mingo@kernel.org> wrote:

>
> * Nadav Amit <namit@vmware.com> wrote:
>
>> Use assembly macros for jump-labels and call them from inline assembly.
>> This not only makes the code more readable, but also improves
>> compilation decision, specifically inline decisions which GCC base on
>> the number of new lines in inline assembly.
>>
>> As a result the code size is slightly increased.
>>
>> text data bss dec hex filename
>> 18163528 10226300 2957312 31347140 1de51c4 ./vmlinux before
>> 18163608 10227348 2957312 31348268 1de562c ./vmlinux after (+1128)
>>
>> And functions such as intel_pstate_adjust_policy_max(),
>> kvm_cpu_accept_dm_intr(), kvm_register_readl() are inlined.
>>
>> Cc: Thomas Gleixner <tglx@linutronix.de>
>> Cc: Ingo Molnar <mingo@redhat.com>
>> Cc: "H. Peter Anvin" <hpa@zytor.com>
>> Cc: x86@kernel.org
>> Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
>> Cc: Kate Stewart <kstewart@linuxfoundation.org>
>> Cc: Philippe Ombredanne <pombredanne@nexb.com>
>> Acked-by: Peter Zijlstra (Intel) <peterz@infradead.org>
>> Signed-off-by: Nadav Amit <namit@vmware.com>
>> ---
>> arch/x86/entry/calling.h | 2 +-
>> arch/x86/include/asm/jump_label.h | 77 +++++++++++--------------------
>> arch/x86/kernel/macros.S | 1 +
>> 3 files changed, 30 insertions(+), 50 deletions(-)
>
> So I tried the series, and this patch causes a silent hard hang on bootup, with no
> (early-)console messages visible.
>
> I've attached the config that triggers the problem, built with:
>
> gcc version 5.3.1 20160406 (Red Hat 5.3.1-6) (GCC)
>
> it's 100% reproducible on both Intel and AMD test systems.
>
> I'll continue to test the series with this patch left out.
>
> So both the xtensa build failure and this boot failure needs to be fixed before I
> can apply this series.

I’ll look into these issues, but I don’t see the config attached.

Thanks,
Nadav
\
 
 \ /
  Last update: 2018-07-24 18:31    [W:0.112 / U:0.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site