lkml.org 
[lkml]   [2018]   [Jul]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Linux 4.18-rc6
From
Date


On 07/24/2018 08:18 AM, Martin Schwidefsky wrote:
> On Mon, 23 Jul 2018 16:17:22 -0700
> Linus Torvalds <torvalds@linux-foundation.org> wrote:
>
>> On Mon, Jul 23, 2018 at 2:23 PM Guenter Roeck <linux@roeck-us.net> wrote:
>>>
>>>>
>>>> Martin - can we just remove the
>>>>
>>>> select HAVE_GCC_PLUGINS
>>>>
>>>> from the s390 Kconfig file (or perhaps add "if BROKEN" or something to
>>>> disable it).
>>>>
>>>> Because if it's not getting fixed, it shouldn't be exposed.
>>>>
>>> The problem only affects 4.18 - the code has been rearranged in -next.
>>> Only, in my builders, I can't disable a flag for individual releases,
>>> so I just disabled it completely for s390.
>>
>> Well, I'm not going to release a 4.18 with a known problem, so in 4.18
>> this *will* be disabled if it's not fixed.
>>
>> The fact that it might be fixed in linux-next is entirely immaterial
>> to the release of 4.18.
>
> Ok, if gcc with the plugins and an allmodconfig is considered to be
> important enough to warrant a fix, it can be pulled from here:
>
> git://git.kernel.org/pub/scm/linux/kernel/git/s390/linux.git for-linus
>
> Martin Schwidefsky (1):
> s390: disable gcc plugins
>
> Once that is in I will create another patch to undo this one and place
> it after the early boot rework.

On the list a different fix was proposed about 2 weeks ago,

something like

CFLAGS_als.o += $(DISABLE_LATENT_ENTROPY_PLUGIN)

and I prefer that. Because your patch disables all gcc plugins.

\
 
 \ /
  Last update: 2018-07-24 09:16    [W:0.093 / U:1.872 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site