lkml.org 
[lkml]   [2018]   [Jul]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjecth8300: BUG: Bad page state in process swapper (was: Re: why do we still need bootmem allocator?)
(added Yoshinori Sato, here's the beginning of the discussion:
https://lore.kernel.org/lkml/20180625140754.GB29102@dhcp22.suse.cz/)

On Wed, Jun 27, 2018 at 07:02:06PM +0300, Mike Rapoport wrote:
> On Wed, Jun 27, 2018 at 07:33:55AM -0600, Rob Herring wrote:
> > On Wed, Jun 27, 2018 at 5:27 AM Mike Rapoport <rppt@linux.vnet.ibm.com> wrote:
> > >
> > > I've tried running the current upstream on h8300 gdb simulator and it
> > > failed:
> >
> > It seems my patch[1] is still not applied. The maintainer said he applied it.
>
> I've applied it manually. Without it unflatten_and_copy_device_tree() fails
> to allocate memory. It indeed can be fixed with moving bootmem_init()
> before, as you've noted in the commit message.
>
> I'll try to dig deeper into it.
>
> > > [ 0.000000] BUG: Bad page state in process swapper pfn:00004
> > > [ 0.000000] page:007ed080 count:0 mapcount:-128 mapping:00000000
> > > index:0x0
> > > [ 0.000000] flags: 0x0()
> > > [ 0.000000] raw: 00000000 0040bdac 0040bdac 00000000 00000000 00000002
> > > ffffff7f 00000000
> > > [ 0.000000] page dumped because: nonzero mapcount
> > > ---Type <return> to continue, or q <return> to quit---
> > > [ 0.000000] CPU: 0 PID: 0 Comm: swapper Not tainted 4.18.0-rc2+ #50
> > > [ 0.000000] Stack from 00401f2c:
> > > [ 0.000000] 00401f2c 001116cb 007ed080 00401f40 000e20e6 00401f54
> > > 0004df14 00000000
> > > [ 0.000000] 007ed080 007ed000 00401f5c 0004df8c 00401f90 0004e982
> > > 00000044 00401fd1
> > > [ 0.000000] 007ed000 007ed000 00000000 00000004 00000008 00000000
> > > 00000003 00000011
> > > [ 0.000000]
> > > [ 0.000000] Call Trace:
> > > [ 0.000000] [<000e20e6>] [<0004df14>] [<0004df8c>] [<0004e982>]
> > > [ 0.000000] [<00051a28>] [<00001000>] [<00000100>]
> > > [ 0.000000] Disabling lock debugging due to kernel taint
> > >
> > > With v4.13 I was able to get to "no valid init found".
> > >
> > > I had a quick look at h8300 memory initialization and it seems it has
> > > starting pfn set to 0 while fdt defines memory start at 4M.
> >
> > Perhaps there's another issue.

In my setup this is caused by __ffs() clobbering start pfn in
nobootmem.c::__free_pages_memory().

If I change the __ffs() implementation from the inline assembly to generic
bitops everything is fine.

I'm using gcc 8.1.0 from [1] and gdb 8.1.0.20180625-git

[1] http://cdn.kernel.org/pub/tools/crosstool/files/bin/x86_64/


--
Sincerely yours,

\
 
 \ /
  Last update: 2018-07-01 14:23    [W:0.090 / U:4.192 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site