[lkml]   [2018]   [Jun]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [GIT PULL] Kbuild updates for 4.18 (2nd round)
Hi Linus,

2018-06-14 2:49 GMT+09:00 Linus Torvalds <>:
> On Wed, Jun 13, 2018 at 10:29 AM Masahiro Yamada
> <> wrote:
>> I cannot come up with a name better than CC_STACKPROTECTOR_STRONG.
> How about just calling it STACKPROTETOR_STRONG and leaving it at that?

Good idea!

> Make the "CC_HAVE_xyz" model for compiler feature tests, but when
> actually picking an actual option, it's not really about the compiler
> any more, except in the sense that it depends on it.

I agree.

I just respected the original naming,
but CC_ is not sensible any more.

> I guess we could leave the CC_STACKPROTECTOR option as-is, just
> because it apparently has a lot of small uses in actual code too, but
> there is absolutely nothing that uses CONFIG_CC_STACKPROTECTOR_STRONG
> outside of the actual compiler option choice (and config files)

But, I'd like to rename CC_STACKPROTECTOR to STACKPROTECTOR as well.

I guess 30 lines or so in the C code usage.

Could you run sed directly in your tree?

Best Regards
Masahiro Yamada

 \ /
  Last update: 2018-06-13 20:16    [W:0.060 / U:0.672 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site