lkml.org 
[lkml]   [2018]   [May]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v2 15/29] venus: helpers: rename a helper function and use buffer mode from caps
From
Date
Hi Tomasz,

Thanks for the review!

On 05/31/2018 10:59 AM, Tomasz Figa wrote:
> On Tue, May 15, 2018 at 5:06 PM Stanimir Varbanov
> <stanimir.varbanov@linaro.org> wrote:
>>
>> Rename is_reg_unreg_needed() to better name is_dynamic_bufmode() and
>> use buffer mode from enumerated per codec capabilities.
>>
>> Signed-off-by: Stanimir Varbanov <stanimir.varbanov@linaro.org>
>> ---
>> drivers/media/platform/qcom/venus/helpers.c | 21 +++++++++++----------
>> 1 file changed, 11 insertions(+), 10 deletions(-)
>>
>> diff --git a/drivers/media/platform/qcom/venus/helpers.c b/drivers/media/platform/qcom/venus/helpers.c
>> index 2b21f6ed7502..1eda19adbf28 100644
>> --- a/drivers/media/platform/qcom/venus/helpers.c
>> +++ b/drivers/media/platform/qcom/venus/helpers.c
>> @@ -354,18 +354,19 @@ session_process_buf(struct venus_inst *inst, struct vb2_v4l2_buffer *vbuf)
>> return 0;
>> }
>>
>> -static inline int is_reg_unreg_needed(struct venus_inst *inst)
>> +static inline int is_dynamic_bufmode(struct venus_inst *inst)
>
> nit: Could be made bool.

And drop inline I guess? :)

--
regards,
Stan

\
 
 \ /
  Last update: 2018-05-31 10:25    [W:0.053 / U:0.672 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site