lkml.org 
[lkml]   [2018]   [May]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 3/4] rcu: Use better variable names in funnel locking loop
On Wed, May 23, 2018 at 05:54:50PM -0700, Joel Fernandes wrote:
> On Wed, May 23, 2018 at 12:23:49PM -0700, Paul E. McKenney wrote:
> > On Wed, May 23, 2018 at 09:06:17AM -0700, Paul E. McKenney wrote:
> > > On Tue, May 22, 2018 at 11:38:14PM -0700, Joel Fernandes wrote:
> > > > From: "Joel Fernandes (Google)" <joel@joelfernandes.org>
> > > >
> > > > The funnel locking loop in rcu_start_this_gp uses rcu_root as a
> > > > temporary variable while walking the combining tree. This causes a
> > > > tiresome exercise of a code reader reminding themselves that rcu_root
> > > > may not be root. Lets just call it rnp, and rename other variables as
> > > > well to be more appropriate.
> > > >
> > > > Original patch: https://patchwork.kernel.org/patch/10396577/
> > > >
> > > > Signed-off-by: Joel Fernandes <joel@joelfernandes.org>
> > > > Signed-off-by: Joel Fernandes (Google) <joel@joelfernandes.org>
> > >
> > > I used to have double Signed-off-by back when I was seconded to Linaro.
> > > But I am guessing that you want the second and don't need the first
> > > one. Unless you tell me otherwise, I will remove the first one on
> > > my next rebase.
> > >
> > > Anyway, the new variable names are much more clear, good stuff,
> > > queued for further review and testing, thank you!
> >
> > And it looks to me like I should fold in the patchlet below to change to
> > rnp_start in a comment. Please let me know if this would mess things up.
>
> Yes, missed that. Sorry. It looks great, thanks!

Done! And not a problem -- this is after all why we do reviews.

Thanx, Paul

\
 
 \ /
  Last update: 2018-05-24 05:53    [W:0.066 / U:0.200 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site