[lkml]   [2018]   [May]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v6 1/2] acpi: apei: Rename ghes_severity() to ghes_cper_severity()
On Mon, May 21, 2018 at 3:49 PM, Alexandru Gagniuc <> wrote:
> ghes_severity() is a misnomer in this case, as it implies the severity
> of the entire GHES structure. Instead, it maps one CPER value to a
> GHES_SEV* value. ghes_cper_severity() is clearer.

It looks like the *real* reason for this change is that you
re-introduce ghes_severity() as a different function in the second

There are a couple of reasons to avoid that, one of them being that
people will now have to remember what the function did in which kernel
versions. Also, the current name is good enough IMO, so I'm not going
to apply this patch.

 \ /
  Last update: 2018-05-22 10:56    [W:0.100 / U:0.884 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site