lkml.org 
[lkml]   [2018]   [May]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] Use 'imply' with SEV Kconfig CRYPTO dependencies
Date
Use Kconfig imply 'option' when specifying SEV CRYPTO dependencies.

Example configuration:
.
.
CONFIG_CRYPTO_DEV_CCP=y
CONFIG_CRYPTO_DEV_CCP_DD=m
CONFIG_CRYPTO_DEV_SP_CCP=y
CONFIG_CRYPTO_DEV_CCP_CRYPTO=m
CONFIG_CRYPTO_DEV_SP_PSP=y
.
.
CONFIG_KVM_AMD=y
CONFIG_KVM_AMD_SEV=y
.
.

When the CRYPTO_DEV_SP_DD is m, KVM_AMD set to y produces compile time
errors.

Since KVM_AMD_SEV depends on KVM_AMD and CRYPTO_DEV_CCP_DD, the
issue can be prevented by using 'imply' Kconfig option when specifying
the CRYPTO dependencies.

Fixes: 505c9e94d832 ("KVM: x86: prefer "depends on" to "select" for SEV")

Signed-off-by: Janakarajan Natarajan <Janakarajan.Natarajan@amd.com>
---
arch/x86/kvm/Kconfig | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/arch/x86/kvm/Kconfig b/arch/x86/kvm/Kconfig
index 92fd433..d9b16b7 100644
--- a/arch/x86/kvm/Kconfig
+++ b/arch/x86/kvm/Kconfig
@@ -85,7 +85,9 @@ config KVM_AMD_SEV
def_bool y
bool "AMD Secure Encrypted Virtualization (SEV) support"
depends on KVM_AMD && X86_64
- depends on CRYPTO_DEV_CCP && CRYPTO_DEV_CCP_DD && CRYPTO_DEV_SP_PSP
+ imply CRYPTO_DEV_CCP
+ imply CRYPTO_DEV_CCP_DD
+ imply CRYPTO_DEV_SP_PSP
---help---
Provides support for launching Encrypted VMs on AMD processors.

--
2.7.4
\
 
 \ /
  Last update: 2018-05-21 17:14    [W:0.138 / U:4.592 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site