[lkml]   [2018]   [May]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2 3/9] security: define security_kernel_read_blob() wrapper
On Thu, 17 May 2018, Eric W. Biederman wrote:

> Nacked-by: "Eric W. Biederman" <>
> Nack on this sharing nonsense. These two interfaces do not share any
> code in their implementations other than the if statement to distinguish
> between the two cases.

Hmm, it's not even doing that.

There's already an if(!file && read_id == X) { } check and this is another
one being added.

> If we want comprehensible and maintainable code in the security modules
> we need to split these two pieces of functionality apart.

All ima_read is doing in both the old and new case is checking if there's
no file then if it's a certain operation, returning an error.

To echo Eric and Casey's suggestions, how about changing the name of the
hook to security_kernel_read_data() ?

Then ima_read_file() can be changed to ima_read_data(), and then instead
of two if (!file && read_id == X) checks, have:

if (!file) {
switch (read_id) {

James Morris

 \ /
  Last update: 2018-05-18 19:15    [W:0.091 / U:1.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site