lkml.org 
[lkml]   [2018]   [May]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v4 2/3] fs: Convert kiocb rw_hint from enum to u16
Date


On 5/18/18 9:05 AM, Christoph Hellwig wrote:
>> +/* ki_hint changed from enum to u16, make sure rw_hint fits into u16 */
>
> I don't think this comment is very useful.
>
>> +static inline u16 ki_hint_valid(enum rw_hint hint)
>
> I'd call this ki_hint_validate.
>
>> +{
>> + if (hint > MAX_KI_HINT)
>> + return 0;
>> +
>> + return hint;
>
> Nit: kill the empty line.
>

I'll clean this up in the next revision.
\
 
 \ /
  Last update: 2018-05-18 21:54    [W:0.089 / U:1.352 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site