lkml.org 
[lkml]   [2018]   [May]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: `ucsi_acpi: probe of USBC000:00 failed with error -12` on Dell XPS 13 9370
Date


> -----Original Message-----
> From: Paul Menzel [mailto:pmenzel+linux-usb@molgen.mpg.de]
> Sent: Wednesday, May 16, 2018 7:36 AM
> To: Heikki Krogerus
> Cc: Greg KH; linux-usb@vger.kernel.org; linux-kernel@vger.kernel.org; Limonciello,
> Mario
> Subject: Re: `ucsi_acpi: probe of USBC000:00 failed with error -12` on Dell XPS 13
> 9370
>
> Dear Heikki,
>
>
> On 05/16/18 13:58, Heikki Krogerus wrote:
>
> > On Wed, May 16, 2018 at 10:02:26AM +0200, Greg KH wrote:
> >> On Tue, May 15, 2018 at 06:47:37PM +0200, Paul Menzel wrote:
>
> >>> On 05/15/18 18:00, Greg KH wrote:
> >>>> On Tue, May 15, 2018 at 04:34:03PM +0200, Paul Menzel wrote:
> >>>
> >>>>> Linux 4.17-rc5 shows the error below on the Dell XPS 13 9370 with Debian
> >>>>> Sid/unstable.
> >>>>>
> >>>>> ```
> >>>>> [???]
> >>>>> [ 0.440240] usb: port power management may be unreliable
> >>>>> [ 0.441358] usbcore: registered new interface driver usb-storage
> >>>>> [ 0.441367] usbcore: registered new interface driver usbserial_generic
> >>>>> [ 0.441369] usbserial: USB Serial support registered for generic
> >>>>> [ 0.441383] ioremap error for 0x3f799000-0x3f79a000, requested 0x2, got
> >>>>> 0x0
> >>>>> [ 0.441518] ucsi_acpi: probe of USBC000:00 failed with error -12
> >>>>> [???]
> >>>>> ```
> >>>>>
> >>>>> 1. Are the ioremap and ucsi_acpi error related or is a separate report
> >>>>> needed?
> >>>>
> >>>> The ioremap error is what causes ucsi_acpi to fail the probe call (-12
> >>>> is "out of memory".)
> >>>>
> >>>>> 2. Do you know the reason for the ucsi_acpi error?
> >>>>
> >>>> the call to ioremap failed.
> >>>>
> >>>> Does this device really have a working typec connector?
> >>>
> >>> Just to avoid misunderstandings, no device was connected to the laptop
> >>> during my test.
> >>>
> >>> But, from other boots, the Dell docking station TB16 kind of works with it,
> >>> so I???d say the USB Type-C connector is working.
> >>
> >> Ok, good, this might just be the acpi tables not set up properly for
> >> this type of connection. Odd that the tables show it should work,
> >> Heikki should know more about this.
> >
> > The firmware probable has not implemented UCSI on this board. I think
> > Dell always supplies the ACPI device node for UCSI in their acpi
> > tables. The _STA method in that device node is then used to inform the
> > OS if the interface exists or not. The return value for _STA comes
> > probable from BIOS, so this is most likely a BIOS problem.
> >
> > Please note that UCSI will only supply status information to the
> > operating system, so the USB Type-C ports will function normally even
> > without it. The ports are handled in firmware on these platforms.
> >
> > Paul, do you have the latest BIOS?
>
> I had the latest firmware
>
> > DMI: Dell Inc. XPS 13 9370/0F6P3V, BIOS 1.2.1 02/21/2018
>
> until today, when 1.3.2 with the changes below was released [1].
>
> Mario, it’d be great, if the Dell firmware team could start testing with
> Linux releases too to find such issues.

Paul,

The team that sustains platforms does perform Linux testing, but it's not
centered around latest upstream kernel and it's also functionally based (not
reviewing dmesg for new kernel errors) so there are changes in
expectations (viewed as regressions) as you find from time to time.

> Mario, could you please also
> check internally if the Dell firmware team is aware of the issues and
> can incorporate a fix.

Sure I'll inquire internally.

> > Fixes & Enhancements
> > Fixes:
> > - Battery can't charge over 55%
> > - Incorrect Ctrl+Alt+Del log on message with HID Event filter driver
> > - Platform can't boot to the PXE boot environment in Legacy mode via DA300
> > - Correct the flash utility string typo
> > - PCIE Card error shows in Support Assist Tool
> > - Fail 'PCR1 changed' msg prompt in CMD during running TPM PCR cycles in OS
> > - The PCI-to-PCI Bridge will lost while connecting to Dell Thunderbolt Dock TB18
> > - Adjust fan speed
> > - Skips keys when typing fast
> >
> > Enhancements:
> > - None
>
> It’ll take me up to some days to get my hands on the device again. But
> the update should be easy enough thanks to Dell supporting fwupd with
> UEFI Capsule and uploading their updates to the Linux Vendor Firmware
> Service [2].
>
>
> Kind regards,
>
> Paul
>
>
> [1]
> http://www.dell.com/support/home/us/en/04/drivers/driversdetails?driverId=VF23P
> [2] https://fwupd.org/

\
 
 \ /
  Last update: 2018-05-16 17:04    [W:0.376 / U:1.728 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site