lkml.org 
[lkml]   [2018]   [May]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: drivers/platform/x86/dell-smbios-smm.c:99: undefined reference to `dcdbas_smi_request'
From
Date
On 05/12/2018 11:32 AM, Darren Hart wrote:
> On Sat, May 12, 2018 at 05:28:05PM +0800, kbuild test robot wrote:
>> Hi Mario,
>>
>> FYI, the error/warning still remains.
>>
>> tree: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git master
>> head: f0ab773f5c96c29a5227234c4b5a820f5591b74d
>> commit: 25d47027e1003546bfd8964b4423cb39bc2d53e9 platform/x86: dell-smbios: Link all dell-smbios-* modules together
>> date: 9 weeks ago
>> config: x86_64-randconfig-s5-05121617 (attached as .config)
>> compiler: gcc-7 (Debian 7.3.0-16) 7.3.0
>> reproduce:
>> git checkout 25d47027e1003546bfd8964b4423cb39bc2d53e9
>
> This failure:
>
> $ zcat config.gz | grep DCDBAS
> CONFIG_DCDBAS=m <----------
>
> $ zcat config.gz | grep SMBIOS
> CONFIG_DELL_SMBIOS=y <----------
> ddCONFIG_DELL_SMBIOS_WMI=y
> CONFIG_DELL_SMBIOS_SMM=y <----------
>
> Is no longer possible as of:
>
> cc69c88 platform/x86: dell-smbios: Resolve dependency error on DCDBAS
>
> +#
> +# If the DELL_SMBIOS_SMM feature is enabled, the DELL_SMBIOS driver
> +# becomes dependent on the DCDBAS driver. The "depends" line prevents a
> +# configuration where DELL_SMBIOS=y while DCDBAS=m.
> +#
> config DELL_SMBIOS
> tristate "Dell SMBIOS driver"
> + depends on DCDBAS || DCDBAS=n
>

and but yet, in linux-4.17-rc4, with this posted config file (after
using: yes '' |make oldconfig), we can see:

WARNING: unmet direct dependencies detected for DELL_SMBIOS
Depends on [m]: X86 [=y] && X86_PLATFORM_DEVICES [=y] && (DCDBAS [=m] || DCDBAS [=m]=n) && (ACPI_WMI [=y] || ACPI_WMI [=y]=n)
Selected by [y]:
- DELL_WMI [=y] && X86 [=y] && X86_PLATFORM_DEVICES [=y] && ACPI_WMI [=y] && DMI [=y] && INPUT [=y] && (ACPI_VIDEO [=y] || ACPI_VIDEO [=y]=n)

CONFIG_DELL_SMBIOS=y
CONFIG_DELL_SMBIOS_WMI=y
CONFIG_DELL_SMBIOS_SMM=y
# CONFIG_DELL_LAPTOP is not set
CONFIG_DELL_WMI=y
CONFIG_DELL_WMI_DESCRIPTOR=y
CONFIG_ACPI_WMI=y
CONFIG_DELL_RBU=y
CONFIG_DCDBAS=m


I'll stare at it some (more), but no promises.

--
~Randy

\
 
 \ /
  Last update: 2018-05-12 20:51    [W:0.045 / U:0.432 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site