lkml.org 
[lkml]   [2018]   [Mar]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 4.4 163/193] kasan: rework Kconfig settings
From
Date
On Fri, 2018-02-23 at 19:26 +0100, Greg Kroah-Hartman wrote:
> 4.4-stable review patch.  If anyone has any objections, please let me know.
>
> ------------------
>
> From: Arnd Bergmann <arnd@arndb.de>
>
> commit e7c52b84fb18f08ce49b6067ae6285aca79084a8 upstream.
[...]
> --- a/lib/Kconfig.debug
> +++ b/lib/Kconfig.debug
> @@ -197,7 +197,7 @@ config ENABLE_MUST_CHECK
>  config FRAME_WARN
>   int "Warn for stack frames larger than (needs gcc 4.4)"
>   range 0 8192
> - default 0 if KASAN
> + default 2048 if GCC_PLUGIN_LATENT_ENTROPY
>   default 1024 if !64BIT
>  default 2048 if 64BIT
>   help

This doesn't make sense for 4.4. There is no GCC_PLUGIN_LATENT_ENTROPY
in 4.4, and this line wasn't added by the upstream commit.

I think all that was really needed in the backport was to delete the
'default 0', right?

Ben.

--
Ben Hutchings
Software Developer, Codethink Ltd.

\
 
 \ /
  Last update: 2018-03-06 15:30    [W:0.706 / U:2.120 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site