lkml.org 
[lkml]   [2018]   [Mar]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCHv5,5/5] ARM: dts: omap4-droid4: add soundcard
Hi,

On Fri, Mar 23, 2018 at 11:09:30AM +0100, Pavel Machek wrote:
> Hi!
>
> > > # CONFIG_SND_OMAP_SOC_RX51 is not set
> > > # CONFIG_SND_OMAP_SOC_N9 is not set
> > > CONFIG_SND_OMAP_SOC_OMAP_TWL4030=y
> > > CONFIG_SND_OMAP_SOC_OMAP_ABE_TWL6040=y
> >
> > That's not needed (but does not hurt). The Droid 4
> > has no TWL companion chip and uses CPCAP instead.
>
> Aha, thanks. I was doing wild experiments to get something that
> boots... I turned them off.
>
> > > Any ideas?
> >
> > You probably did not enable the soundcard driver, that binds against
> > "audio-graph-card" compatible and connects the codec driver with the
> > SoC driver: CONFIG_SND_AUDIO_GRAPH_CARD
>
> Ok, that certainly changed things; I am now getting this:
>
> Mar 23 08:39:17 devuan kernel: [ 11.633605] asoc-audio-graph-card soundcard: GPIO lookup for
> consumer pa
> Mar 23 08:39:17 devuan kernel: [ 11.644958] asoc-audio-graph-card soundcard: using device tr
> ee for GPIO lookup
> Mar 23 08:39:17 devuan kernel: [ 11.656677] of_get_named_gpiod_flags: can't parse 'pa-gpios'
> property of node '/soundcard[0]'
> Mar 23 08:39:17 devuan kernel: [ 11.669738] of_get_named_gpiod_flags: can't parse 'pa-gpio'
> property of node '/soundcard[0]'
> Mar 23 08:39:17 devuan kernel: [ 11.682617] asoc-audio-graph-card soundcard: using lookup ta
> bles for GPIO lookup
> Mar 23 08:39:17 devuan kernel: [ 11.694427] asoc-audio-graph-card soundcard: lookup for GPIO
> pa failed

That's not an error, but just some debug messages. Consider
disabling CONFIG_DEBUG_GPIO to get rid of them.

> Indeed the dts does not seem to contain any gpios

It's optional and does not exist on Droid 4.

> soundcard {
> compatible = "audio-graph-card";
> label = "Droid 4 Audio";
>
> simple-graph-card,widgets =
> "Speaker", "Earpiece",
> "Speaker", "Loudspeaker",
> "Headphone", "Headphone Jack",
> "Microphone", "Internal Mic";
>
> simple-graph-card,routing =
> "Earpiece", "EP",
> "Loudspeaker", "SPKR",
> "Headphone Jack", "HSL",
> "Headphone Jack", "HSR",
> "MICR", "Internal Mic";
>
> dais = <&mcbsp2_port>, <&mcbsp3_port>;
> };
>
> Any more ideas? :-)

Make sure, that the device was not proped properly (cat
/proc/asound/cards) and post the real error? :)

-- Sebastian
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2018-03-23 11:31    [W:0.172 / U:0.332 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site