lkml.org 
[lkml]   [2018]   [Mar]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: [PATCH 4/4] staging: fsl-dpaa2/eth: allow the driver to compile multi-arch
Date
-----Original Message-----
From: Greg KH [mailto:gregkh@linuxfoundation.org]
Sent: Thursday, March 1, 2018 6:32 PM
To: Ruxandra Ioana Ciocoi Radulescu <ruxandra.radulescu@nxp.com>
Cc: devel@driverdev.osuosl.org; Roy Pledge <roy.pledge@nxp.com>; Bogdan Purcareata <bogdan.purcareata@nxp.com>; linux-kernel@vger.kernel.org; Laurentiu Tudor <laurentiu.tudor@nxp.com>
Subject: Re: [PATCH 4/4] staging: fsl-dpaa2/eth: allow the driver to compile multi-arch

On Mon, Feb 26, 2018 at 10:28:07AM -0600, Ioana Radulescu wrote:
> Drop dependency on ARCH_LAYERSCAPE (which in turn depends on ARM64),
> thus allowing this driver to compile on all architectures supported by
> the fsl-mc bus driver.
>
> This was compile tested on:
> - powerpc (corenet_basic_defconfig, ppc64_defconfig)
> - x86 (i386_defconfig, x86_64_defconfig, needs CONFIG_OF)
> - arm64 (defconfig)

Seems you need to compile it on more things, based on the kbuild warnings :(

Yes I do, sorry for the slip :(

I've added allmodconfig and the sparse endianness flag to my list of tests.
Will send a v2 early next week.

Thanks,
Ioana

\
 
 \ /
  Last update: 2018-03-02 17:56    [W:0.060 / U:0.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site