[lkml]   [2018]   [Feb]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] Update rf_type_definition
This is better.  But the subject should say [PATCH v2] and we need a
driver prefix.

On Wed, Feb 07, 2018 at 06:23:34AM +0900, wrote:
> From: Kangmin Park <>
> enum RT_RF_TYPE_DEFINITION on rtl8723bs/include/rtw_rf.h
> is different from enum tag_HAL_RF_Type_Definition on
> rtl8723bs/include/HalVerDef.h
> So, update them to be the same reference from
> enum rf_type on rtlwifi/wifi.h which recent version.
> As a result, ODM_RF_TYPE_E needs to be updated as well
> Therefore, it is updated reference from enum odm_rf_type
> on rtlwifi/phydm/phydm_pre_define.h too.
> And update some additional code to check more
> chip versions that resulted from it.
> Also, fixed some space required errors and
> line over 80 characters warnings by

Don't do this. It's considered unrelated white space change and it
makes the code hard to review.

To be honest, I don't know the code well enough to say if this patch is
a good idea generally... It seems risky and I wish someone would test
it or a maintainer would Ack it.

dan carpenter

 \ /
  Last update: 2018-02-07 12:15    [W:0.043 / U:1.220 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site