lkml.org 
[lkml]   [2018]   [Feb]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC PATCH v2 5/5] x86/entry/64: open-code switch_to_thread_stack

* Josh Poimboeuf <jpoimboe@redhat.com> wrote:

> > -.macro DO_SWITCH_TO_THREAD_STACK
> > +/* 8(%rsp): ~(interrupt number) */
> > +ENTRY(interrupt_helper)
>
> "interrupt_helper" is a bit vague, how about "interrupt_entry"? That
> better describes its purpose and also makes it more analagous to
> paranoid_entry() and error_entry().

Yeah, interrupt_entry() sounds better - and the renaming should be propagated to
the other patches as well.

Thanks,

Ingo

\
 
 \ /
  Last update: 2018-02-20 08:38    [W:0.122 / U:0.000 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site