lkml.org 
[lkml]   [2018]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] ALSA: usb-audio: Fix UAC2 get_ctl request with a RANGE attribute
On Thu, 08 Feb 2018 07:21:36 +0100,
Kirill Marinushkin wrote:
>
> On 02/07/18 06:45, Takashi Iwai wrote:
> > On Mon, 29 Jan 2018 06:37:55 +0100,
> > Kirill Marinushkin wrote:
> >> The layout of the UAC2 Control request and response varies depending on
> >> the request type. With the current implementation, only the Layout 2
> >> Parameter Block (with the 2-byte sized RANGE attribute) is handled
> >> properly. For the Control requests with the 1-byte sized RANGE attribute
> >> (Bass Control, Mid Control, Tremble Control), the response is parsed
> >> incorrectly.
> >>
> >> This commit:
> >> * fixes the wLength field value in the request
> >> * fixes parsing the range values from the response
> >>
> >> Fixes: 23caaf19b11e ("ALSA: usb-mixer: Add support for Audio Class v2.0")
> >> Signed-off-by: Kirill Marinushkin <k.marinushkin@gmail.com>
> >> Cc: Jaroslav Kysela <perex@perex.cz>
> >> Cc: Takashi Iwai <tiwai@suse.com>
> >> Cc: Jaejoong Kim <climbbb.kim@gmail.com>
> >> Cc: Bhumika Goyal <bhumirks@gmail.com>
> >> Cc: Stephen Barber <smbarber@chromium.org>
> >> Cc: Julian Scheel <julian@jusst.de>
> >> Cc: alsa-devel@alsa-project.org
> >> Cc: linux-kernel@vger.kernel.org
> > Sorry for the late reply, as I've been (and still) off.
> >
> > Does this bug actually hit on any real devices, or is it only a
> > logical error so far? In the former case, a Cc to stable is
> > mandatory.
> >
> > In anyway, I'll review and merge it properly once after I back to
> > work.
> >
> >
> > thanks,
> >
> > Takashi
>
> Hello Takashi,
>
> Thank you for your answer. I will wait until you are back to work, don't
> worry about the late replies.
>
> I did not hit the issue on a real device.
>
> During my UAC2 experiments, I reproduced this issue on the development
> board, and then tested my solution on it.

OK, if it happened on a development system, it's a real issue, and we
should put Cc to stable. Now I applied the patch.

Thanks!


Takashi

\
 
 \ /
  Last update: 2018-02-12 09:09    [W:0.286 / U:32.900 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site